# CVE-2025-58352: Weblate has long session expiry times during second factor verification

> Attackers can bypass second factor authentication rate limiting due to long session expiry times in Weblate.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 5 Sep 2025
- **Also known as:** GHSA-377j-wj38-4728, PYSEC-2026-2036

## What is CVE-2025-58352?

CVE-2025-58352 is a low-severity vulnerability in WeblateOrg weblate, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the  second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-58352?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.13.1 |
| `weblate` | PyPI | All versions | 5.13.1 |
| `Weblate` | PyPI | All versions | 5.13.1 |

Products: Weblate Weblate.

## How do I fix CVE-2025-58352?

Upgrade weblate to 5.13.1 or later.

## Is CVE-2025-58352 being exploited?

There is no known exploitation of CVE-2025-58352 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58352 and fix it if it is affected.

What it is: CVE-2025-58352 is a low-severity vulnerability in WeblateOrg weblate, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58352 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.13.1
- weblate (PyPI): affected all versions; fixed in 5.13.1
- Weblate (PyPI): affected all versions; fixed in 5.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58352/ (Markdown: https://insights.sbomify.com/CVE-2025-58352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58352
- OSV: https://osv.dev/vulnerability/CVE-2025-58352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58352/
Summaries are generated and may contain mistakes; the official description above is the record.
