CVE-2025-58355 Soft Serve is vulnerable to arbitrary file writing through its SSH API

High 7.7 Published Updated

Attackers can write arbitrary files via the SSH API, potentially leading to code execution or data modification on the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-58355?

CVE-2025-58355 is a high-severity path traversal vulnerability in charmbracelet soft-serve, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Soft Serve is a self-hostable Git server for the command line. In versions 0.9.1 and below, attackers can create or override arbitrary files with uncontrolled data through its SSH API. This issue is fixed in version 0.10.0.

Weakness: CWE-22

Which versions are affected by CVE-2025-58355?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.

PackageAffectedFixed in
github.com/charmbracelet/soft-serve GoAll versions0.10.0
github.com/charmbracelet/soft-serve GoAll versions0.10.0
github.com/charmbracelet/soft-serve GoAll versions0.10.0

How do I fix CVE-2025-58355?

Upgrade github.com/charmbracelet/soft-serve to 0.10.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-58355 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58355 exists.

Sources

Also known as GHSA-33pr-m977-5w97, GO-2025-3930.

Is CVE-2025-58355 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free