{"answers":{"affected":"3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58355 exists.","fix":"Upgrade github.com/charmbracelet/soft-serve to 0.10.0 or later.","what":"CVE-2025-58355 is a high-severity path traversal vulnerability in charmbracelet soft-serve, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58355 and fix it if it is affected.\n\nWhat it is: CVE-2025-58355 is a high-severity path traversal vulnerability in charmbracelet soft-serve, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58355 exists.\n\nAffected packages and fixed versions:\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58355/ (Markdown: https://insights.sbomify.com/CVE-2025-58355/index.md)","id":"CVE-2025-58355","markdown":"https://insights.sbomify.com/CVE-2025-58355/index.md","name":"CVE-2025-58355","record":{"aliases":["GHSA-33pr-m977-5w97","GO-2025-3930"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Git server","requires_auth":"low_privilege","summary":"Attackers can write arbitrary files via the SSH API, potentially leading to code execution or data modification on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Soft Serve is a self-hostable Git server for the command line. In versions 0.9.1 and below, attackers can create or override arbitrary files with uncontrolled data through its SSH API. This issue is fixed in version 0.10.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Soft Serve is vulnerable to arbitrary file writing through its SSH API","id":"CVE-2025-58355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Constellation allows insecure use of LUKS2 persistent storage partitions","id":"CVE-2025-58356"},"packages":[{"ecosystem":"Go","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":null,"source":"GHSA-33pr-m977-5w97"},{"ecosystem":"Go","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":"pkg:golang/github.com/charmbracelet/soft-serve","source":"GHSA-33pr-m977-5w97"},{"ecosystem":"Go","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":"pkg:golang/github.com/charmbracelet/soft-serve","source":"GO-2025-3930"}],"prev":{"headline":"Kata Containers coco-tdx malicious host can circumvent initdata verification","id":"CVE-2025-58354"},"products":["soft-serve"],"published":"2025-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-04","vendors":["charmbracelet"]},"summary":"Attackers can write arbitrary files via the SSH API, potentially leading to code execution or data modification on the server.","url":"https://insights.sbomify.com/CVE-2025-58355/"}