# CVE-2025-58355: Soft Serve is vulnerable to arbitrary file writing through its SSH API

> Attackers can write arbitrary files via the SSH API, potentially leading to code execution or data modification on the server.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Sep 2025
- **Also known as:** GHSA-33pr-m977-5w97, GO-2025-3930

## What is CVE-2025-58355?

CVE-2025-58355 is a high-severity path traversal vulnerability in charmbracelet soft-serve, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Soft Serve is a self-hostable Git server for the command line. In versions 0.9.1 and below, attackers can create or override arbitrary files with uncontrolled data through its SSH API. This issue is fixed in version 0.10.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-58355?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.10.0 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.10.0 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.10.0 |

## How do I fix CVE-2025-58355?

Upgrade github.com/charmbracelet/soft-serve to 0.10.0 or later.

## Is CVE-2025-58355 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58355 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58355 and fix it if it is affected.

What it is: CVE-2025-58355 is a high-severity path traversal vulnerability in charmbracelet soft-serve, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58355 exists.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58355/ (Markdown: https://insights.sbomify.com/CVE-2025-58355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58355
- OSV: https://osv.dev/vulnerability/CVE-2025-58355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58355/
Summaries are generated and may contain mistakes; the official description above is the record.
