{"answers":{"affected":"2 open source packages ship an affected version, including mcp-markdownify-server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58358 exists.","fix":"Upgrade mcp-markdownify-server to 0.0.2 or later.","what":"CVE-2025-58358 is a high-severity command injection vulnerability in zcaceres markdownify-mcp, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58358 and fix it if it is affected.\n\nWhat it is: CVE-2025-58358 is a high-severity command injection vulnerability in zcaceres markdownify-mcp, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58358 exists.\n\nAffected packages and fixed versions:\n- mcp-markdownify-server (npm): affected all versions; fixed in 0.0.2\n- mcp-markdownify-server (npm): affected all versions; fixed in 0.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58358/ (Markdown: https://insights.sbomify.com/CVE-2025-58358/index.md)","id":"CVE-2025-58358","markdown":"https://insights.sbomify.com/CVE-2025-58358/index.md","name":"CVE-2025-58358","record":{"aliases":["GHSA-45qj-4xq3-3c45"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Markdownify MCP server","requires_auth":"none","summary":"An attacker can execute arbitrary system commands via unsanitized input in the pptx-to-markdown tool, leading to remote code execution.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Markdownify is a Model Context Protocol server for converting almost anything to Markdown. Versions below 0.0.2 contain a command injection vulnerability, caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, \u003e, \u0026\u0026, etc.). This issue is fixed in version 0.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Markdownify is vulnerable to command injection through pptx-to-markdown tool","id":"CVE-2025-58358","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"frost-core: refresh shares with smaller min_signers will reduce group security","id":"CVE-2025-58359"},"packages":[{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"mcp-markdownify-server","purl":null,"source":"GHSA-45qj-4xq3-3c45"},{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"mcp-markdownify-server","purl":"pkg:npm/mcp-markdownify-server","source":"GHSA-45qj-4xq3-3c45"}],"prev":{"headline":"5ire Chat Message XSS Vulnerability Enables Remote Code Execution","id":"CVE-2025-58357"},"products":["markdownify-mcp"],"published":"2025-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-04","vendors":["zcaceres"]},"summary":"An attacker can execute arbitrary system commands via unsanitized input in the pptx-to-markdown tool, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-58358/"}