# CVE-2025-58358: Markdownify is vulnerable to command injection through pptx-to-markdown tool

> An attacker can execute arbitrary system commands via unsanitized input in the pptx-to-markdown tool, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 4 Sep 2025
- **Also known as:** GHSA-45qj-4xq3-3c45

## What is CVE-2025-58358?

CVE-2025-58358 is a high-severity command injection vulnerability in zcaceres markdownify-mcp, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Markdownify is a Model Context Protocol server for converting almost anything to Markdown. Versions below 0.0.2 contain a command injection vulnerability, caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). This issue is fixed in version 0.0.2.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-58358?

2 open source packages ship an affected version, including mcp-markdownify-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-markdownify-server` | npm | All versions | 0.0.2 |
| `mcp-markdownify-server` | npm | All versions | 0.0.2 |

## How do I fix CVE-2025-58358?

Upgrade mcp-markdownify-server to 0.0.2 or later.

## Is CVE-2025-58358 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58358 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58358 and fix it if it is affected.

What it is: CVE-2025-58358 is a high-severity command injection vulnerability in zcaceres markdownify-mcp, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58358 exists.

Affected packages and fixed versions:
- mcp-markdownify-server (npm): affected all versions; fixed in 0.0.2
- mcp-markdownify-server (npm): affected all versions; fixed in 0.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58358/ (Markdown: https://insights.sbomify.com/CVE-2025-58358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58358
- OSV: https://osv.dev/vulnerability/CVE-2025-58358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58358/
Summaries are generated and may contain mistakes; the official description above is the record.
