# CVE-2025-58359: frost-core: refresh shares with smaller min_signers will reduce group security

> Incorrect handling of threshold updates in FROST key refresh allows attackers to reduce group security and bypass intended signing thresholds.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 5 Sep 2025
- **Also known as:** GHSA-wgq8-vr6r-mqxm

## What is CVE-2025-58359?

CVE-2025-58359 is a medium-severity vulnerability in ZcashFoundation frost, published on 4 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZF FROST is a Rust implementation of FROST (Flexible Round-Optimised Schnorr Threshold signatures). In versions 2.0.0 through 2.1.0, refresh shares with smaller min_signers will reduce security of group. The inability to change min_signers (i.e. the threshold) with the refresh share functionality (frost_core::keys::refresh module) was not made clear to users. Using a smaller value would not decrease the threshold, and attempts to sign using a smaller threshold would fail. Additionally, after refreshing the shares with a smaller threshold, it would still be possible to sign with the original threshold, potentially causing a security loss to the participant's shares. This issue is fixed in version 2.2.0.

Weakness: CWE-325 (Missing Cryptographic Step)

## Which versions are affected by CVE-2025-58359?

2 open source packages ship an affected version, including frost-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frost-core` | crates.io | From 2.0.0 | 2.2.0 |
| `frost-core` | crates.io | From 2.0.0 | 2.2.0 |

## How do I fix CVE-2025-58359?

Upgrade frost-core to 2.2.0 or later.

## Is CVE-2025-58359 being exploited?

There is no known exploitation of CVE-2025-58359 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58359 and fix it if it is affected.

What it is: CVE-2025-58359 is a medium-severity vulnerability in ZcashFoundation frost, published on 4 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58359 in the wild and no public exploit code.

Affected packages and fixed versions:
- frost-core (crates.io): affected from 2.0.0; fixed in 2.2.0
- frost-core (crates.io): affected from 2.0.0; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58359/ (Markdown: https://insights.sbomify.com/CVE-2025-58359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58359
- OSV: https://osv.dev/vulnerability/CVE-2025-58359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58359/
Summaries are generated and may contain mistakes; the official description above is the record.
