CVE-2025-58360 OSGeo GeoServer Improper Restriction of XML External Entity Reference
An unauthenticated attacker can exploit an XXE vulnerability in GeoServer's WMS GetMap endpoint to read sensitive data or cause denial of service.
- Exploited in the wild
- Since 11 Dec 2025
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58360?
CVE-2025-58360 is a high-severity vulnerability in geoserver, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Weakness: CWE-611
Which versions are affected by CVE-2025-58360?
8 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver:gs-wms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver.web:gs-web-app Maven | All versions | 2.25.6 |
org.geoserver.web:gs-web-app Maven | All versions | 2.25.6 |
org.geoserver.web:gs-web-app Maven | From 2.26.0 | 2.26.2 |
org.geoserver.web:gs-web-app Maven | From 2.26.0 | 2.26.2 |
org.geoserver:gs-wms Maven | All versions | 2.25.6 |
org.geoserver:gs-wms Maven | All versions | 2.25.6 |
2 more packages
org.geoserver:gs-wms Maven | From 2.26.0 | 2.26.2 |
org.geoserver:gs-wms Maven | From 2.26.0 | 2.26.2 |
Products include Geoserver Geoserver.
How do I fix CVE-2025-58360?
Upgrade org.geoserver.web:gs-web-app to a fixed version for your release line: 2.25.6 or 2.26.2. US federal agencies must fix it by 1 Jan 2026.
Is CVE-2025-58360 being exploited?
Yes. Attackers have exploited CVE-2025-58360 in the wild since at least 11 Dec 2025.
Public exploit code: 1 Metasploit module, 1 Nuclei template and 6 proofs of concept on GitHub.
Other vulnerabilities in geoserver
- CVE-2024-36401 OSGeo GeoServer GeoTools Eval Injection
- CVE-2023-35042 GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language
- CVE-2024-24749 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
- CVE-2023-41877 GeoServer log file path traversal vulnerability
- CVE-2023-51444 GeoServer arbitrary file upload vulnerability in REST Coverage Store API
Sources
Also known as GHSA-fjf5-xgmq-5525.