# CVE-2025-58360: OSGeo GeoServer Improper Restriction of XML External Entity Reference

> An unauthenticated attacker can exploit an XXE vulnerability in GeoServer's WMS GetMap endpoint to read sensitive data or cause denial of service.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Yes, since 11 Dec 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-fjf5-xgmq-5525

## What is CVE-2025-58360?

CVE-2025-58360 is a high-severity vulnerability in geoserver, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-58360?

8 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver:gs-wms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.25.6 |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.25.6 |
| `org.geoserver.web:gs-web-app` | Maven | From 2.26.0 | 2.26.2 |
| `org.geoserver.web:gs-web-app` | Maven | From 2.26.0 | 2.26.2 |
| `org.geoserver:gs-wms` | Maven | All versions | 2.25.6 |
| `org.geoserver:gs-wms` | Maven | All versions | 2.25.6 |
| `org.geoserver:gs-wms` | Maven | From 2.26.0 | 2.26.2 |
| `org.geoserver:gs-wms` | Maven | From 2.26.0 | 2.26.2 |

Products: Geoserver Geoserver.

## How do I fix CVE-2025-58360?

Upgrade org.geoserver.web:gs-web-app to a fixed version for your release line: 2.25.6 or 2.26.2. US federal agencies must fix it by 1 Jan 2026.

## Is CVE-2025-58360 being exploited?

Yes. Attackers have exploited CVE-2025-58360 in the wild since at least 11 Dec 2025.

Public exploit code:

- XXE through a specific endpoint /geoserver/wms operation GetMap - Geoserver (github_poc): https://github.com/quyenheu/CVE-2025-58360
- A new way to exploit CVE-2025-58360 bypass WAF (github_poc): https://github.com/quyenheu/Bypass-CVE-2025-58360
- https://github.com/thomas-osgood/cve-2025-58360 (github_poc): https://github.com/thomas-osgood/cve-2025-58360
- GeoServer WMS GetMap XXE Arbitrary File Read (metasploit)
- CVE-2025-58360 (github_poc): https://github.com/carlzhang123/Blackash-CVE-2025-58360
- Passive detection for CVE-2025-58360 (github_poc): https://github.com/rxerium/CVE-2025-58360

## Other vulnerabilities in geoserver

- [CVE-2024-36401](https://insights.sbomify.com/CVE-2024-36401/): OSGeo GeoServer GeoTools Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2023-35042](https://insights.sbomify.com/CVE-2023-35042/): GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language (critical 9.8)
- [CVE-2024-24749](https://insights.sbomify.com/CVE-2024-24749/): Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat (high 7.5)
- [CVE-2023-41877](https://insights.sbomify.com/CVE-2023-41877/): GeoServer log file path traversal vulnerability (high 7.2)
- [CVE-2023-51444](https://insights.sbomify.com/CVE-2023-51444/): GeoServer arbitrary file upload vulnerability in REST Coverage Store API (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58360 and fix it if it is affected.

What it is: CVE-2025-58360 is a high-severity vulnerability in geoserver, published on 25 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-58360 in the wild since at least 11 Dec 2025.

Affected packages and fixed versions:
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.6
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.6
- org.geoserver.web:gs-web-app (Maven): affected from 2.26.0; fixed in 2.26.2
- org.geoserver.web:gs-web-app (Maven): affected from 2.26.0; fixed in 2.26.2
- org.geoserver:gs-wms (Maven): affected all versions; fixed in 2.25.6
- org.geoserver:gs-wms (Maven): affected all versions; fixed in 2.25.6
- org.geoserver:gs-wms (Maven): affected from 2.26.0; fixed in 2.26.2
- org.geoserver:gs-wms (Maven): affected from 2.26.0; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58360/ (Markdown: https://insights.sbomify.com/CVE-2025-58360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58360
- OSV: https://osv.dev/vulnerability/CVE-2025-58360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58360/
Summaries are generated and may contain mistakes; the official description above is the record.
