# CVE-2025-58362: Hono contains a flaw in URL path parsing, potentially leading to path confusion

> Flaw in Hono's URL parsing allows path confusion, potentially bypassing proxy ACLs to access protected endpoints like /admin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 5 Sep 2025
- **Also known as:** GHSA-9hp6-4448-45g2

## What is CVE-2025-58362?

CVE-2025-58362 is a high-severity path traversal vulnerability in honojs hono, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. Versions 4.8.0 through 4.9.5 contain a flaw in the getPath utility function which could allow path confusion and potential bypass of proxy-level ACLs (e.g. Nginx location blocks). The original implementation relied on fixed character offsets when parsing request URLs. Under certain malformed absolute-form Request-URIs, this could lead to incorrect path extraction depending on the application and environment. If proxy ACLs are used to protect sensitive endpoints such as /admin, this flaw could have allowed unauthorized access. The confidentiality impact depends on what data is exposed: if sensitive administrative data is exposed, the impact may be high, otherwise it may be moderate. This issue is fixed in version 4.9.6.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2025-58362?

2 open source packages ship an affected version, including hono. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | From 4.8.0 | 4.9.6 |
| `hono` | npm | From 4.8.0 | 4.9.6 |

Products: Hono Hono.

## How do I fix CVE-2025-58362?

Upgrade hono to 4.9.6 or later.

## Is CVE-2025-58362 being exploited?

There is no known exploitation of CVE-2025-58362 in the wild and no public exploit code.

## Other vulnerabilities in honojs hono

- [CVE-2026-27700](https://insights.sbomify.com/CVE-2026-27700/): Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo (high 8.2)
- [CVE-2026-22817](https://insights.sbomify.com/CVE-2026-22817/): JWT Algorithm Confusion via Unsafe Default (HS256) in Hono JWT Middleware Allows Token Forgery and Auth Bypass (high 8.2)
- [CVE-2026-22818](https://insights.sbomify.com/CVE-2026-22818/): JWT algorithm confusion in Hono JWK Auth Middleware when JWK lacks "alg" (untrusted header.alg fallback) (high 8.2)
- [CVE-2025-62610](https://insights.sbomify.com/CVE-2025-62610/): Hono Improperly Authorizes JWT Audience Validation (high 8.1)
- [CVE-2026-29045](https://insights.sbomify.com/CVE-2026-29045/): Hono: Arbitrary file access via serveStatic vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58362 and fix it if it is affected.

What it is: CVE-2025-58362 is a high-severity path traversal vulnerability in honojs hono, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58362 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected from 4.8.0; fixed in 4.9.6
- hono (npm): affected from 4.8.0; fixed in 4.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58362/ (Markdown: https://insights.sbomify.com/CVE-2025-58362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58362
- OSV: https://osv.dev/vulnerability/CVE-2025-58362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58362/
Summaries are generated and may contain mistakes; the official description above is the record.
