{"answers":{"affected":"2 open source packages ship an affected version, including org.xwiki.contrib.blog:application-blog-ui.","exploited":"There is no known exploitation of CVE-2025-58365 in the wild and no public exploit code.","fix":"Upgrade org.xwiki.contrib.blog:application-blog-ui to 9.14 or later.","what":"CVE-2025-58365 is a high-severity code injection vulnerability in xwiki-contrib application-blog, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58365 and fix it if it is affected.\n\nWhat it is: CVE-2025-58365 is a high-severity code injection vulnerability in xwiki-contrib application-blog, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58365 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.xwiki.contrib.blog:application-blog-ui (Maven): affected all versions; fixed in 9.14\n- org.xwiki.contrib.blog:application-blog-ui (Maven): affected all versions; fixed in 9.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58365/ (Markdown: https://insights.sbomify.com/CVE-2025-58365/index.md)","id":"CVE-2025-58365","markdown":"https://insights.sbomify.com/CVE-2025-58365/index.md","name":"CVE-2025-58365","record":{"aliases":["GHSA-gwj6-xpfg-pxwr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki blog application","requires_auth":"low_privilege","summary":"Attackers with edit rights can execute arbitrary code via blog post content, leading to privilege escalation and remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Prior to version 9.14, the blog application in XWiki allowed remote code execution for any user who has edit right on any page. Normally, these are all logged-in users as they can edit their own user profile. For an exploit, it is sufficient to add an object of type `Blog.BlogPostClass` to any page and to add some script macro with the exploit code to the \"Content\" field of that object. The vulnerability has been patched in the blog application version 9.14 by executing the content of blog posts with the rights of the appropriate author. No known workarounds are available.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XWiki Blog Application: Privilege Escalation (PR) from account through blog content","id":"CVE-2025-58365","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Onyxia private helm repository credentials are leaked through unauthenticated API","id":"CVE-2025-58366"},"packages":[{"ecosystem":"Maven","fixed":["9.14"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib.blog:application-blog-ui","purl":null,"source":"GHSA-gwj6-xpfg-pxwr"},{"ecosystem":"Maven","fixed":["9.14"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib.blog:application-blog-ui","purl":"pkg:maven/org.xwiki.contrib.blog/application-blog-ui","source":"GHSA-gwj6-xpfg-pxwr"}],"prev":{"headline":"cups: Remote DoS via null dereference","id":"CVE-2025-58364"},"products":["application-blog"],"published":"2025-09-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-09","vendors":["xwiki-contrib"]},"summary":"Attackers with edit rights can execute arbitrary code via blog post content, leading to privilege escalation and remote code execution.","url":"https://insights.sbomify.com/CVE-2025-58365/"}