# CVE-2025-58366: Onyxia private helm repository credentials are leaked through unauthenticated API

> Unauthenticated attackers can retrieve private Helm repository credentials from the public catalogs endpoint in Onyxia.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-m773-6vm8-8x6q

## What is CVE-2025-58366?

CVE-2025-58366 is a critical vulnerability in InseeFrLab onyxia, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Onyxia is a data science environment for kubernetes. In versions 4.6.0 through 4.8.0, Onyxia-API leaked the credentials of private helm repositories in the public (unauthenticated) /public/catalogs endpoint.vOnly instances using private helm repositories (i.e setting username & password in the catalogs configuration) are affected. This is fixed in version 4.9.0.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-58366?


## How do I fix CVE-2025-58366?

No fix has been published for CVE-2025-58366 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58366 being exploited?

There is no known exploitation of CVE-2025-58366 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58366 and fix it if it is affected.

What it is: CVE-2025-58366 is a critical vulnerability in InseeFrLab onyxia, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58366 in the wild and no public exploit code.

Affected product: InseeFrLab onyxia. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58366/ (Markdown: https://insights.sbomify.com/CVE-2025-58366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58366
- OSV: https://osv.dev/vulnerability/CVE-2025-58366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58366/
Summaries are generated and may contain mistakes; the official description above is the record.
