# CVE-2025-58371: Roo Code is vulnerable to command injection via GitHub actions workflow

> Attackers can achieve remote code execution on GitHub Actions runners via unsanitized pull request metadata, compromising repository secrets and integrity.

- **Severity:** Critical 9.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-xr6r-vj48-29f6

## What is CVE-2025-58371?

CVE-2025-58371 is a critical command injection vulnerability in RooCodeInc Roo-Code, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.26.6 and below, a Github workflow used unsanitized pull request metadata in a privileged context, allowing an attacker to craft malicious input and achieve Remote Code Execution (RCE) on the Actions runner. The workflow runs with broad permissions and access to repository secrets. It is possible for an attacker to execute arbitrary commands on the runner, push or modify code in the repository, access secrets, and create malicious releases or packages, resulting in a complete compromise of the repository and its associated services. This is fixed in version 3.26.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-58371?

It affects 1 product.


Products: Roocode Roo Code.

## How do I fix CVE-2025-58371?

No fix has been published for CVE-2025-58371 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58371 being exploited?

There is no known exploitation of CVE-2025-58371 in the wild and no public exploit code.

Public exploit code:

- Security-research lab: reproduction of CVE-2025-58371 (GitHub Actions command injection via PR title in Discord PR Notifier), snapshot of RooCodeInc/Roo-Code @ 08a825f9bb0086a88cff5a79b9af4731bba7d076 (github_poc): https://github.com/pvharmo2/gha-lab-d14c91f1bb

## Other vulnerabilities in RooCodeInc Roo-Code

- [CVE-2026-30307](https://insights.sbomify.com/CVE-2026-30307/): Command injection in n/a (critical 9.8)
- [CVE-2025-65946](https://insights.sbomify.com/CVE-2025-65946/): Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug (high 8.1)
- [CVE-2025-58370](https://insights.sbomify.com/CVE-2025-58370/): Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference (high 8.1)
- [CVE-2025-58372](https://insights.sbomify.com/CVE-2025-58372/): Roo Code: Potential Remote Code Execution via .code-workspace (high 8.1)
- [CVE-2025-53536](https://insights.sbomify.com/CVE-2025-53536/): Roo Code allows Potential Remote Code Execution via .vscode/settings.json (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58371 and fix it if it is affected.

What it is: CVE-2025-58371 is a critical command injection vulnerability in RooCodeInc Roo-Code, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58371 in the wild and no public exploit code.

Affected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58371/ (Markdown: https://insights.sbomify.com/CVE-2025-58371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58371
- OSV: https://osv.dev/vulnerability/CVE-2025-58371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58371/
Summaries are generated and may contain mistakes; the official description above is the record.
