CVE-2025-58372 Roo Code: Potential Remote Code Execution via .code-workspace

High 8.1 Published Updated

Attackers can achieve remote code execution by injecting malicious tasks into workspace files if auto-approval is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-58372?

CVE-2025-58372 is a high-severity code injection vulnerability in RooCodeInc Roo-Code, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions 3.25.23 and below contain a vulnerability where certain VS Code workspace configuration files (.code-workspace) are not protected in the same way as the .vscode folder. If the agent was configured to auto-approve file writes, an attacker able to influence prompts (for example via prompt injection) could cause malicious workspace settings or tasks to be written. These tasks could then be executed automatically when the workspace is reopened, resulting in arbitrary code execution. This issue is fixed in version 3.26.0.

Weakness: CWE-94, CWE-732

Which versions are affected by CVE-2025-58372?

It affects 1 product.

Products include Roocode Roo Code.

How do I fix CVE-2025-58372?

No fix has been published for CVE-2025-58372 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-58372 being exploited?

There is no known exploitation of CVE-2025-58372 in the wild and no public exploit code.

Sources

Also known as GHSA-4pqh-4ggm-jfmm.

Is CVE-2025-58372 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free