{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58374 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-58374 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-58374 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 6 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58374 and fix it if it is affected.\n\nWhat it is: CVE-2025-58374 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 6 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-58374 in the wild and no public exploit code.\n\nAffected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58374/ (Markdown: https://insights.sbomify.com/CVE-2025-58374/index.md)","id":"CVE-2025-58374","markdown":"https://insights.sbomify.com/CVE-2025-58374/index.md","name":"CVE-2025-58374","record":{"aliases":["GHSA-c292-qxq4-4p2v"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"VS Code extension","requires_auth":"none","summary":"Attackers can execute arbitrary code via malicious npm postinstall scripts when auto-approve is enabled in Roo Code.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"roo_code","vendor":"roocode"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions 3.25.23 and below contain a default list of allowed commands that do not need manual approval if auto-approve is enabled, and npm install is included in that list. Because npm install executes lifecycle scripts, if a repository’s package.json file contains a malicious postinstall script, it would be executed automatically without user approval. This means that enabling auto-approved commands and opening a malicious repo could result in arbitrary code execution. This is fixed in version 3.26.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Roo Code: Auto-approve allows npm install execution of malicious postinstall scripts","id":"CVE-2025-58374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Frappe has potential SQL Injection due to missing validation","id":"CVE-2025-58375"},"packages":[],"prev":{"headline":"Roo Code: Symlink-bypass of .rooignore can lead to unintended file disclosure","id":"CVE-2025-58373"},"products":["Roo-Code"],"published":"2025-09-06","related":[{"cvss_score":9.9,"headline":"Roo Code is vulnerable to command injection via GitHub actions workflow","id":"CVE-2025-58371","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2026-30307","kev_date_added":null,"published":"2026-03-30"},{"cvss_score":8.1,"headline":"Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug","id":"CVE-2025-65946","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":8.1,"headline":"Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference","id":"CVE-2025-58370","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":8.1,"headline":"Roo Code: Potential Remote Code Execution via .code-workspace","id":"CVE-2025-58372","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":8.1,"headline":"Roo Code allows Potential Remote Code Execution via .vscode/settings.json","id":"CVE-2025-53536","kev_date_added":null,"published":"2025-07-07"},{"cvss_score":8.1,"headline":"Roo Code Vulnerable to Potential Remote Code Execution via Model Context Protocol","id":"CVE-2025-53098","kev_date_added":null,"published":"2025-06-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-08","vendors":["RooCodeInc"]},"summary":"Attackers can execute arbitrary code via malicious npm postinstall scripts when auto-approve is enabled in Roo Code.","url":"https://insights.sbomify.com/CVE-2025-58374/"}