# CVE-2025-58374: Roo Code: Auto-approve allows npm install execution of malicious postinstall scripts

> Attackers can execute arbitrary code via malicious npm postinstall scripts when auto-approve is enabled in Roo Code.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-c292-qxq4-4p2v

## What is CVE-2025-58374?

CVE-2025-58374 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 6 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions 3.25.23 and below contain a default list of allowed commands that do not need manual approval if auto-approve is enabled, and npm install is included in that list. Because npm install executes lifecycle scripts, if a repository’s package.json file contains a malicious postinstall script, it would be executed automatically without user approval. This means that enabling auto-approved commands and opening a malicious repo could result in arbitrary code execution. This is fixed in version 3.26.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-58374?

It affects 1 product.


Products: Roocode Roo Code.

## How do I fix CVE-2025-58374?

No fix has been published for CVE-2025-58374 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58374 being exploited?

There is no known exploitation of CVE-2025-58374 in the wild and no public exploit code.

## Other vulnerabilities in RooCodeInc Roo-Code

- [CVE-2025-58371](https://insights.sbomify.com/CVE-2025-58371/): Roo Code is vulnerable to command injection via GitHub actions workflow (critical 9.9)
- [CVE-2026-30307](https://insights.sbomify.com/CVE-2026-30307/): Command injection in n/a (critical 9.8)
- [CVE-2025-65946](https://insights.sbomify.com/CVE-2025-65946/): Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug (high 8.1)
- [CVE-2025-58370](https://insights.sbomify.com/CVE-2025-58370/): Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference (high 8.1)
- [CVE-2025-58372](https://insights.sbomify.com/CVE-2025-58372/): Roo Code: Potential Remote Code Execution via .code-workspace (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58374 and fix it if it is affected.

What it is: CVE-2025-58374 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 6 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58374 in the wild and no public exploit code.

Affected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58374/ (Markdown: https://insights.sbomify.com/CVE-2025-58374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58374
- OSV: https://osv.dev/vulnerability/CVE-2025-58374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58374/
Summaries are generated and may contain mistakes; the official description above is the record.
