CVE-2025-58375 Frappe has potential SQL Injection due to missing validation
Attackers can exploit an insecure endpoint to perform error-based SQL injection and retrieve sensitive information from Frappe web applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-58375?
CVE-2025-58375 is a high-severity SQL injection vulnerability in frappe, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Frappe is a full-stack web application framework. Versions 14.96.9 and below, and 15.0.0 through 15.71.0 have an insecure endpoint parameter that is vulnerable to error-based SQL Injection through lack of validation. Sensitive information such as versioning can be retrieved. This issue is fixed in versions 14.96.10 and 15.72.0.
Weakness: CWE-89
Which versions are affected by CVE-2025-58375?
How do I fix CVE-2025-58375?
No fix has been published for CVE-2025-58375 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-58375 being exploited?
There is no known exploitation of CVE-2025-58375 in the wild and no public exploit code.
Sources
Also known as GHSA-m666-2494-p975.