# CVE-2025-58375: Frappe has potential SQL Injection due to missing validation

> Attackers can exploit an insecure endpoint to perform error-based SQL injection and retrieve sensitive information from Frappe web applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-m666-2494-p975

## What is CVE-2025-58375?

CVE-2025-58375 is a high-severity SQL injection vulnerability in frappe, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Versions 14.96.9 and below, and 15.0.0 through 15.71.0 have an insecure endpoint parameter that is vulnerable to error-based SQL Injection through lack of validation. Sensitive information such as versioning can be retrieved. This issue is fixed in versions 14.96.10 and 15.72.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-58375?


## How do I fix CVE-2025-58375?

No fix has been published for CVE-2025-58375 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58375 being exploited?

There is no known exploitation of CVE-2025-58375 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58375 and fix it if it is affected.

What it is: CVE-2025-58375 is a high-severity SQL injection vulnerability in frappe, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58375 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58375/ (Markdown: https://insights.sbomify.com/CVE-2025-58375/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58375
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58375
- OSV: https://osv.dev/vulnerability/CVE-2025-58375

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58375/
Summaries are generated and may contain mistakes; the official description above is the record.
