# CVE-2025-58434: Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover

> Unauthenticated password reset token disclosure allows attackers to take over any user account in Flowise deployments.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-wgpv-6j63-x5ph

## What is CVE-2025-58434?

CVE-2025-58434 is a critical vulnerability in Flowiseai Flowise, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5 and earlier, the `forgot-password` endpoint in Flowise returns sensitive information including a valid password reset `tempToken` without authentication or verification. This enables any attacker to generate a reset token for arbitrary users and directly reset their password, leading to a complete account takeover (ATO). This vulnerability applies to both the cloud service (`cloud.flowiseai.com`) and self-hosted/local Flowise deployments that expose the same API. Commit 9e178d68873eb876073846433a596590d3d9c863 in version 3.0.6 secures password reset endpoints. Several recommended remediation steps are available. Do not return reset tokens or sensitive account details in API responses. Tokens must only be delivered securely via the registered email channel. Ensure `forgot-password` responds with a generic success message regardless of input, to avoid user enumeration. Require strong validation of the `tempToken` (e.g., single-use, short expiry, tied to request origin, validated against email delivery). Apply the same fixes to both cloud and self-hosted/local deployments. Log and monitor password reset requests for suspicious activity. Consider multi-factor verification for sensitive accounts.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-58434?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.6 |
| `flowise` | npm | All versions | 3.0.6 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-58434?

Upgrade flowise to 3.0.6 or later.

## Is CVE-2025-58434 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58434 exists.

Public exploit code:

- Combined PoC for CVE-2025-28434 and CVE-2025-59528 (github_poc): https://github.com/kartik2005221/CVE-2025-58434-AND-59528-POC
- CVE-2025-58434 and CVE-2025-59528 chain POC (github_poc): https://github.com/AzureADTrent/CVE-2025-58434-59528
- Exploitation Silentium HTB-CTF (github_poc): https://github.com/jwsly12/CVE-2025-58434-59528-htb-ctf
- Critical unauthenticated kill chain leading to full RCE in FlowiseAI (CVE-2025-58434 + CVE-2025-59528) (github_poc): https://github.com/CVETeam/FlowiseAI-Critical-KillChain
- https://github.com/kartik2005221/CVE-2025-58434-poc (github_poc): https://github.com/kartik2005221/CVE-2025-58434-poc
- Unauthenticated password reset exploit for Flowise AI ≤ 3.0.5. Abuses the /api/v1/account/forgot-password endpoint to change any user's password without prior authentication. Includes a proof-of-concept script and mitigation guidelines. (github_poc): https://github.com/arensballiu/Flowise-CVE-2025-58434-PasswordReset

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58434 and fix it if it is affected.

What it is: CVE-2025-58434 is a critical vulnerability in Flowiseai Flowise, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58434 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.6
- flowise (npm): affected all versions; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58434/ (Markdown: https://insights.sbomify.com/CVE-2025-58434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58434
- OSV: https://osv.dev/vulnerability/CVE-2025-58434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58434/
Summaries are generated and may contain mistakes; the official description above is the record.
