CVE-2025-58436 OpenPrinting CUPS slow client can halt cupsd, leading to a possible DoS attack
A slow client can halt the CUPS daemon, causing a denial of service for other users by delaying processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58436?
CVE-2025-58436 is a medium-severity denial of service vulnerability in OpenPrinting cups, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a client that connects to cupsd but sends slow messages, e.g. only one byte per second, delays cupsd as a whole, such that it becomes unusable by other clients. This issue has been patched in version 2.4.15.
Weakness: CWE-400
Which versions are affected by CVE-2025-58436?
It affects 1 product.
Linux distribution packages (22)
cups SUSE:Linux Enterprise Micro 5.2 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Micro 5.2 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Micro 5.3 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Micro 5.3 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Micro 5.4 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Micro 5.4 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Micro 5.5 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Micro 5.5 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 2.2.7-150000.3.83.1 |
cups SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 2.2.7-150000.3.80.1 |
cups SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 2.2.7-150000.3.83.1 |
cups openSUSE:Leap 15.6 | All versions | 2.2.7-150000.3.80.1 |
cups openSUSE:Leap 15.6 | All versions | 2.2.7-150000.3.83.1 |
Products include Openprinting Cups.
How do I fix CVE-2025-58436?
Apply the vendor's patch.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-58436 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58436 exists.
Other vulnerabilities in OpenPrinting cups
- CVE-2025-58060 cups has Authentication bypass with AuthType Negotiate
- CVE-2026-34978 Path traversal in cups
- CVE-2025-58364 cups: Remote DoS via null dereference
- CVE-2026-34980 OpenPrinting CUPS: Shared PostScript queue lets anonymous Print-Job requests reach `lp` code execution over the network
- CVE-2025-61915 OpenPrinting CUPS vulnerable to stack based out-of-bound write
Sources
Also known as ALPINE-CVE-2025-58436, AZL-71143, AZL-71149, BELL-CVE-2025-58436, CLSA-2026-1768210674, CLSA-2026-1768224866 and 17 more.