CVE-2025-58439 ERP: Possibility of SQL injection due to missing validation
Attackers can exploit missing parameter validation in ERPNext endpoints to perform error-based SQL injection and retrieve sensitive information like version details.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-58439?
CVE-2025-58439 is a high-severity SQL injection vulnerability in Frappe Erpnext, published on 6 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
ERP is a free and open source Enterprise Resource Planning tool. In versions below 14.89.2 and 15.0.0 through 15.75.1, lack of validation of parameters left certain endpoints vulnerable to error-based SQL Injection. Some information like version could be retrieved. This issue is fixed in versions 14.89.2 and 15.76.0.
Weakness: CWE-89
Which versions are affected by CVE-2025-58439?
It affects 1 product.
Products include Frappe Erpnext.
How do I fix CVE-2025-58439?
No fix has been published for CVE-2025-58439 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-58439 being exploited?
There is no known exploitation of CVE-2025-58439 in the wild and no public exploit code.
Other vulnerabilities in Frappe Erpnext
Sources
Also known as GHSA-fvjw-5w9q-6v39, GHSA-hqcw-m9w9-7qxh.