# CVE-2025-58439: ERP: Possibility of SQL injection due to missing validation

> Attackers can exploit missing parameter validation in ERPNext endpoints to perform error-based SQL injection and retrieve sensitive information like version details.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** GHSA-fvjw-5w9q-6v39, GHSA-hqcw-m9w9-7qxh

## What is CVE-2025-58439?

CVE-2025-58439 is a high-severity SQL injection vulnerability in Frappe Erpnext, published on 6 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ERP is a free and open source Enterprise Resource Planning tool. In versions below 14.89.2 and 15.0.0 through 15.75.1, lack of validation of parameters left certain endpoints vulnerable to error-based SQL Injection. Some information like version could be retrieved. This issue is fixed in versions 14.89.2 and 15.76.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-58439?

It affects 1 product.


Products: Frappe Erpnext.

## How do I fix CVE-2025-58439?

No fix has been published for CVE-2025-58439 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58439 being exploited?

There is no known exploitation of CVE-2025-58439 in the wild and no public exploit code.

## Other vulnerabilities in Frappe Erpnext

- [CVE-2026-44442](https://insights.sbomify.com/CVE-2026-44442/): ERPNext: Unauthorised Document modification due to missing validation (critical 9.9)
- [CVE-2026-38431](https://insights.sbomify.com/CVE-2026-38431/): Code injection in n/a (critical 9.8)
- [CVE-2025-66438](https://insights.sbomify.com/CVE-2025-66438/): Code injection in n/a (critical 9.8)
- [CVE-2025-66439](https://insights.sbomify.com/CVE-2025-66439/): SQL injection in n/a (critical 9.8)
- [CVE-2025-66440](https://insights.sbomify.com/CVE-2025-66440/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58439 and fix it if it is affected.

What it is: CVE-2025-58439 is a high-severity SQL injection vulnerability in Frappe Erpnext, published on 6 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58439 in the wild and no public exploit code.

Affected product: Frappe Erpnext. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58439/ (Markdown: https://insights.sbomify.com/CVE-2025-58439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58439
- OSV: https://osv.dev/vulnerability/CVE-2025-58439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58439/
Summaries are generated and may contain mistakes; the official description above is the record.
