# CVE-2025-58444: MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server

> An XSS vulnerability in the MCP Inspector allows attackers to execute arbitrary commands when connecting to malicious servers.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-g9hg-qhmf-q45m

## What is CVE-2025-58444?

CVE-2025-58444 is a high-severity cross-site scripting vulnerability in modelcontextprotocol inspector, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.

Weakness: CWE-84 (Improper Neutralization of Encoded URI Schemes in a Web Page)

## Which versions are affected by CVE-2025-58444?

2 open source packages ship an affected version, including @modelcontextprotocol/inspector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@modelcontextprotocol/inspector` | npm | All versions | 0.16.6 |
| `@modelcontextprotocol/inspector` | npm | All versions | 0.16.6 |

## How do I fix CVE-2025-58444?

Upgrade @modelcontextprotocol/inspector to 0.16.6 or later.

## Is CVE-2025-58444 being exploited?

There is no known exploitation of CVE-2025-58444 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58444 and fix it if it is affected.

What it is: CVE-2025-58444 is a high-severity cross-site scripting vulnerability in modelcontextprotocol inspector, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58444 in the wild and no public exploit code.

Affected packages and fixed versions:
- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.16.6
- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.16.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58444/ (Markdown: https://insights.sbomify.com/CVE-2025-58444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58444
- OSV: https://osv.dev/vulnerability/CVE-2025-58444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58444/
Summaries are generated and may contain mistakes; the official description above is the record.
