# CVE-2025-58449: Maho Vulnerable to Authenticated Remote Code Execution via File Upload

> Authenticated staff users can upload malicious PHP files via product options, leading to remote code execution on the Maho ecommerce platform.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-vgmm-27fc-vmgp

## What is CVE-2025-58449?

CVE-2025-58449 is a high-severity vulnerability in MahoCommerce maho, published on 8 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Maho is a free and open source ecommerce platform. In Maho prior to 25.9.0, an authenticated staff user with access to the `Dashboard` and `Catalog\Manage Products` permissions can create a custom option on a listing with a file input field. By allowing file uploads with a `.php` extension, the user can use the filed to upload malicious PHP files, gaining remote code execution. Version 25.9.0 fixes the issue.

Weakness: CWE-646 (Reliance on File Name or Extension of Externally-Supplied File)

## Which versions are affected by CVE-2025-58449?

2 open source packages ship an affected version, including mahocommerce/maho.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mahocommerce/maho` | Packagist | All versions | 25.9.0 |
| `mahocommerce/maho` | Packagist | All versions | 25.9.0 |

## How do I fix CVE-2025-58449?

Upgrade mahocommerce/maho to 25.9.0 or later.

## Is CVE-2025-58449 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58449 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58449 and fix it if it is affected.

What it is: CVE-2025-58449 is a high-severity vulnerability in MahoCommerce maho, published on 8 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58449 exists.

Affected packages and fixed versions:
- mahocommerce/maho (Packagist): affected all versions; fixed in 25.9.0
- mahocommerce/maho (Packagist): affected all versions; fixed in 25.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58449/ (Markdown: https://insights.sbomify.com/CVE-2025-58449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58449
- OSV: https://osv.dev/vulnerability/CVE-2025-58449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58449/
Summaries are generated and may contain mistakes; the official description above is the record.
