# CVE-2025-58451: Cattown Vulnerable to Inefficient Regular Expression Complexity and Uncontrolled Resource Consumption


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-455v-w7r9-3vv9

## What is CVE-2025-58451?

CVE-2025-58451 is a high-severity vulnerability in IEatUranium238 Cattown, published on 8 Sep 2025. 

### Official description

Cattown is a JavaScript markdown parser. Versions prior to 1.0.2 used regular expressions with inefficient, potentially exponential worst-case complexity. This could cause excessive CPU usage due to excessive backtracking on crafted inputs. In turn, the excessive CPU usage could lead to resource exhaustion, where processing malicious inputs could cause high CPU or memory usage, potentially leading to denial of service. Version 1.0.2 contains a patch. Additionally, users should review and restrict input sources if untrusted inputs are processed.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-58451?

2 open source packages ship an affected version, including cattown.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cattown` | npm | All versions | 1.0.2 |
| `cattown` | npm | All versions | 1.0.2 |

## How do I fix CVE-2025-58451?

Upgrade cattown to 1.0.2 or later.

## Is CVE-2025-58451 being exploited?

There is no known exploitation of CVE-2025-58451 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58451 and fix it if it is affected.

What it is: CVE-2025-58451 is a high-severity vulnerability in IEatUranium238 Cattown, published on 8 Sep 2025. 
Exploitation: There is no known exploitation of CVE-2025-58451 in the wild and no public exploit code.

Affected packages and fixed versions:
- cattown (npm): affected all versions; fixed in 1.0.2
- cattown (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58451/ (Markdown: https://insights.sbomify.com/CVE-2025-58451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58451
- OSV: https://osv.dev/vulnerability/CVE-2025-58451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58451/
Summaries are generated and may contain mistakes; the official description above is the record.
