CVE-2025-58457 Apache ZooKeeper: Insufficient Permission Check in AdminServer Snapshot/Restore Commands

Medium 4.3 Published Updated

Authorized clients can execute snapshot and restore commands with insufficient permissions, allowing unauthorized data access or modification in Apache ZooKeeper.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-58457?

CVE-2025-58457 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions.

This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4.

Users are recommended to upgrade to version 3.9.4, which fixes the issue.

The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)

Weakness: CWE-280

Which versions are affected by CVE-2025-58457?

3 open source packages ship an affected version, including org.apache.zookeeper:zookeeper and zookeeper. It affects 1 product.

PackageAffectedFixed in
org.apache.zookeeper:zookeeper MavenFrom 3.9.03.9.4
org.apache.zookeeper:zookeeper MavenFrom 3.9.03.9.4
zookeeper BitnamiFrom 3.9.03.9.4

Products include Apache Zookeeper.

How do I fix CVE-2025-58457?

Upgrade org.apache.zookeeper:zookeeper to 3.9.4 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-58457 being exploited?

There is no known exploitation of CVE-2025-58457 in the wild and no public exploit code.

Sources

Also known as BIT-zookeeper-2025-58457, DEBIAN-CVE-2025-58457, GHSA-2hmj-97jw-28jh, MINI-48x2-mm8g-v5vm, MINI-8f68-jf2c-xg3q, MINI-gwf3-5cgp-857w and 3 more.

Is CVE-2025-58457 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free