{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.zookeeper:zookeeper and zookeeper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58457 in the wild and no public exploit code.","fix":"Upgrade org.apache.zookeeper:zookeeper to 3.9.4 or later.","what":"CVE-2025-58457 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58457 and fix it if it is affected.\n\nWhat it is: CVE-2025-58457 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58457 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.4\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.4\n- zookeeper (Bitnami): affected from 3.9.0; fixed in 3.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58457/ (Markdown: https://insights.sbomify.com/CVE-2025-58457/index.md)","id":"CVE-2025-58457","markdown":"https://insights.sbomify.com/CVE-2025-58457/index.md","name":"CVE-2025-58457","record":{"aliases":["BIT-zookeeper-2025-58457","DEBIAN-CVE-2025-58457","GHSA-2hmj-97jw-28jh","MINI-48x2-mm8g-v5vm","MINI-8f68-jf2c-xg3q","MINI-gwf3-5cgp-857w","MINI-xvjp-33xg-852j","ROOT-APP-MAVEN-CVE-2025-58457","UBUNTU-CVE-2025-58457"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Distributed coordination service","requires_auth":"low_privilege","summary":"Authorized clients can execute snapshot and restore commands with insufficient permissions, allowing unauthorized data access or modification in Apache ZooKeeper.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zookeeper","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-280","name":"Improper Handling of Insufficient Permissions or Privileges"}],"description":"Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions.\n\nThis issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4.\n\nUsers are recommended to upgrade to version 3.9.4, which fixes the issue.\n\nThe issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ZooKeeper: Insufficient Permission Check in AdminServer Snapshot/Restore Commands","id":"CVE-2025-58457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Jenkins Git client Plugin file system information disclosure vulnerability","id":"CVE-2025-58458"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.4"],"introduced":["3.9.0"],"last_affected":[],"package":"zookeeper","purl":"pkg:bitnami/zookeeper","source":"BIT-zookeeper-2025-58457"},{"ecosystem":"Maven","fixed":["3.9.4"],"introduced":["3.9.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":null,"source":"GHSA-2hmj-97jw-28jh"},{"ecosystem":"Maven","fixed":["3.9.4"],"introduced":["3.9.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":"pkg:maven/org.apache.zookeeper/zookeeper","source":"GHSA-2hmj-97jw-28jh"}],"prev":{"headline":"AutomationDirect Productivity Suite Relative Path Traversal","id":"CVE-2025-58456"},"products":["Apache ZooKeeper"],"published":"2025-09-24","related":[{"cvss_score":9.1,"headline":"Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server","id":"CVE-2024-51504","kev_date_added":null,"published":"2024-11-07"},{"cvss_score":9.1,"headline":"Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication","id":"CVE-2023-44981","kev_date_added":null,"published":"2023-10-11"},{"cvss_score":8.1,"headline":"Memory corruption in n/a","id":"CVE-2016-5017","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":7.5,"headline":"Apache ZooKeeper: Information disclosure via SetWatches reconnect replay","id":"CVE-2026-59739","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode","id":"CVE-2026-59969","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Missing authorization in Apache ZooKeeper","id":"CVE-2026-79993","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Missing Authorization in Apache ZooKeeper","id":"CVE-2018-8012","kev_date_added":null,"published":"2018-05-21"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Authorized clients can execute snapshot and restore commands with insufficient permissions, allowing unauthorized data access or modification in Apache ZooKeeper.","url":"https://insights.sbomify.com/CVE-2025-58457/"}