# CVE-2025-58457: Apache ZooKeeper: Insufficient Permission Check in AdminServer Snapshot/Restore Commands

> Authorized clients can execute snapshot and restore commands with insufficient permissions, allowing unauthorized data access or modification in Apache ZooKeeper.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-zookeeper-2025-58457, DEBIAN-CVE-2025-58457, GHSA-2hmj-97jw-28jh, MINI-48x2-mm8g-v5vm, MINI-8f68-jf2c-xg3q, MINI-gwf3-5cgp-857w, MINI-xvjp-33xg-852j, ROOT-APP-MAVEN-CVE-2025-58457, UBUNTU-CVE-2025-58457

## What is CVE-2025-58457?

CVE-2025-58457 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions.

This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4.

Users are recommended to upgrade to version 3.9.4, which fixes the issue.

The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)

Weakness: CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2025-58457?

3 open source packages ship an affected version, including org.apache.zookeeper:zookeeper and zookeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.4 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.4 |
| `zookeeper` | Bitnami | From 3.9.0 | 3.9.4 |

Products: Apache Zookeeper.

## How do I fix CVE-2025-58457?

Upgrade org.apache.zookeeper:zookeeper to 3.9.4 or later.

## Is CVE-2025-58457 being exploited?

There is no known exploitation of CVE-2025-58457 in the wild and no public exploit code.

## Other vulnerabilities in Apache ZooKeeper

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58457 and fix it if it is affected.

What it is: CVE-2025-58457 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58457 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.4
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.4
- zookeeper (Bitnami): affected from 3.9.0; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58457/ (Markdown: https://insights.sbomify.com/CVE-2025-58457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58457
- OSV: https://osv.dev/vulnerability/CVE-2025-58457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58457/
Summaries are generated and may contain mistakes; the official description above is the record.
