# CVE-2025-58460: Jenkins OpenTelemetry Plugin missing permission check allows capturing credentials

> Attackers with read access can capture Jenkins credentials by connecting to an attacker-controlled URL due to missing permission checks.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-f696-867g-2759

## What is CVE-2025-58460?

CVE-2025-58460 is a medium-severity missing authorization vulnerability in Jenkins OpenTelemetry Plugin, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins OpenTelemetry Plugin 3.1543.v8446b_92b_cd64 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-58460?

2 open source packages ship an affected version, including io.jenkins.plugins:opentelemetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:opentelemetry` | Maven | All versions | 3.1543.1545.vf5a |
| `io.jenkins.plugins:opentelemetry` | Maven | All versions | 3.1543.1545.vf5a |

Products: Jenkins Opentelemetry.

## How do I fix CVE-2025-58460?

Upgrade io.jenkins.plugins:opentelemetry to 3.1543.1545.vf5a or later.

## Is CVE-2025-58460 being exploited?

There is no known exploitation of CVE-2025-58460 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58460 and fix it if it is affected.

What it is: CVE-2025-58460 is a medium-severity missing authorization vulnerability in Jenkins OpenTelemetry Plugin, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58460 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:opentelemetry (Maven): affected all versions; fixed in 3.1543.1545.vf5a
- io.jenkins.plugins:opentelemetry (Maven): affected all versions; fixed in 3.1543.1545.vf5a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58460/ (Markdown: https://insights.sbomify.com/CVE-2025-58460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58460
- OSV: https://osv.dev/vulnerability/CVE-2025-58460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58460/
Summaries are generated and may contain mistakes; the official description above is the record.
