# CVE-2025-5864: Tenda TDSEE App Password Reset Confirmation Code ConfirmSmsCode excessive authentication

> Attackers can bypass rate limits on password reset confirmation codes, potentially enabling brute-force attacks against user accounts.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-vm2g-hvc6-gm5m

## What is CVE-2025-5864?

CVE-2025-5864 is a medium-severity vulnerability in Tenda TDSEE App, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Tenda TDSEE App up to 1.7.12. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /app/ConfirmSmsCode of the component Password Reset Confirmation Code Handler. The manipulation leads to improper restriction of excessive authentication attempts. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.15 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-799 (Improper Control of Interaction Frequency), CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-5864?


## How do I fix CVE-2025-5864?

No fix has been published for CVE-2025-5864 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5864 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5864 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5864 and fix it if it is affected.

What it is: CVE-2025-5864 is a medium-severity vulnerability in Tenda TDSEE App, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5864 exists.

Affected product: Tenda TDSEE App. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5864/ (Markdown: https://insights.sbomify.com/CVE-2025-5864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5864
- OSV: https://osv.dev/vulnerability/CVE-2025-5864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5864/
Summaries are generated and may contain mistakes; the official description above is the record.
