{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2025-58674 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.8.3 or later.","what":"CVE-2025-58674 is a medium-severity cross-site scripting vulnerability in WordPress, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58674 and fix it if it is affected.\n\nWhat it is: CVE-2025-58674 is a medium-severity cross-site scripting vulnerability in WordPress, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-58674 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 6.8.3\n- wordpress-multisite (Bitnami): affected all versions; fixed in 6.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58674/ (Markdown: https://insights.sbomify.com/CVE-2025-58674/index.md)","id":"CVE-2025-58674","markdown":"https://insights.sbomify.com/CVE-2025-58674/index.md","name":"CVE-2025-58674","record":{"aliases":["BIT-wordpress-2025-58674","BIT-wordpress-multisite-2025-58674","DEBIAN-CVE-2025-58674","GHSA-73p8-vhmr-7r6r","MINI-862c-m2g8-96vc","UBUNTU-CVE-2025-58674"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"high_privilege","summary":"An attacker with Author privileges can inject malicious scripts into WordPress pages, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPress allows Stored XSS. WordPress core security team is aware of the issue and working on a fix. This is low severity vulnerability that requires an attacker to have Author or higher user privileges to execute the attack vector.This issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress \u003c= 6.8.2 - (Author+) Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-58674","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress Interact: Embed A Quiz On Your Site Plugin \u003c= 3.1 - Cross Site Request Forgery (CSRF) Vulnerability","id":"CVE-2025-58675"},"packages":[{"ecosystem":"Bitnami","fixed":["6.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2025-58674"},{"ecosystem":"Bitnami","fixed":["6.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2025-58674"}],"prev":{"headline":"WordPress WP User Frontend Plugin \u003c= 4.1.12 - Content Injection Vulnerability","id":"CVE-2025-58673"},"products":["WordPress"],"published":"2025-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["WordPress"]},"summary":"An attacker with Author privileges can inject malicious scripts into WordPress pages, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2025-58674/"}