# CVE-2025-58674: WordPress <= 6.8.2 - (Author+) Cross Site Scripting (XSS) Vulnerability

> An attacker with Author privileges can inject malicious scripts into WordPress pages, potentially compromising other users' sessions.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 28 Apr 2026
- **Also known as:** BIT-wordpress-2025-58674, BIT-wordpress-multisite-2025-58674, DEBIAN-CVE-2025-58674, GHSA-73p8-vhmr-7r6r, MINI-862c-m2g8-96vc, UBUNTU-CVE-2025-58674

## What is CVE-2025-58674?

CVE-2025-58674 is a medium-severity cross-site scripting vulnerability in WordPress, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPress allows Stored XSS. WordPress core security team is aware of the issue and working on a fix. This is low severity vulnerability that requires an attacker to have Author or higher user privileges to execute the attack vector.This issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-58674?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 6.8.3 |
| `wordpress-multisite` | Bitnami | All versions | 6.8.3 |

## How do I fix CVE-2025-58674?

Upgrade wordpress to 6.8.3 or later.

## Is CVE-2025-58674 being exploited?

There is no known exploitation of CVE-2025-58674 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58674 and fix it if it is affected.

What it is: CVE-2025-58674 is a medium-severity cross-site scripting vulnerability in WordPress, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58674 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 6.8.3
- wordpress-multisite (Bitnami): affected all versions; fixed in 6.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58674/ (Markdown: https://insights.sbomify.com/CVE-2025-58674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58674
- OSV: https://osv.dev/vulnerability/CVE-2025-58674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58674/
Summaries are generated and may contain mistakes; the official description above is the record.
