# CVE-2025-58754: Axios is vulnerable to DoS attack through lack of data size check

> An attacker can cause a denial of service by sending a large data URI, leading to unbounded memory allocation in the Axios HTTP client.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 16 Jan 2026
- **Also known as:** CLEANSTART-2026-NK05110, CLSA-2026-1783904635, DEBIAN-CVE-2025-58754, ECHO-807d-c2a5-2a03, GHSA-4hjh-wcwx-xvwj, MINI-3gj5-qqmv-w6r6, MINI-7v59-rr65-2rwx, MINI-f6qp-vvh5-mmhc, MINI-ff5w-2rpr-cjjv, MINI-fvcm-6gf4-g2wh, MINI-ghc3-xffm-7wcp, MINI-h47q-pw95-6prg, MINI-qj4x-4q5j-xg5p, ROOT-APP-NPM-CVE-2025-58754, UBUNTU-CVE-2025-58754

## What is CVE-2025-58754?

CVE-2025-58754 is a high-severity denial of service vulnerability in axios, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. When Axios starting in version 0.28.0 and prior to versions 0.30.2 and 1.12.0 runs on Node.js and is given a URL with the `data:` scheme, it does not perform HTTP. Instead, its Node http adapter decodes the entire payload into memory (`Buffer`/`Blob`) and returns a synthetic 200 response. This path ignores `maxContentLength` / `maxBodyLength` (which only protect HTTP responses), so an attacker can supply a very large `data:` URI and cause the process to allocate unbounded memory and crash (DoS), even if the caller requested `responseType: 'stream'`. Versions 0.30.2 and 1.12.0 contain a patch for the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-58754?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.28.0 | 0.30.2 |
| `axios` | npm | From 0.28.0 | 0.30.2 |
| `axios` | npm | From 1.0.0 | 1.12.0 |
| `axios` | npm | From 1.0.0 | 1.12.0 |

Products: Axios Axios.

## How do I fix CVE-2025-58754?

Upgrade axios to a fixed version for your release line: 0.30.2 or 1.12.0.

## Is CVE-2025-58754 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58754 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58754 and fix it if it is affected.

What it is: CVE-2025-58754 is a high-severity denial of service vulnerability in axios, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58754 exists.

Affected packages and fixed versions:
- axios (npm): affected from 0.28.0; fixed in 0.30.2
- axios (npm): affected from 0.28.0; fixed in 0.30.2
- axios (npm): affected from 1.0.0; fixed in 1.12.0
- axios (npm): affected from 1.0.0; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58754/ (Markdown: https://insights.sbomify.com/CVE-2025-58754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58754
- OSV: https://osv.dev/vulnerability/CVE-2025-58754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58754/
Summaries are generated and may contain mistakes; the official description above is the record.
