# CVE-2025-58756: MONAI's unsafe torch usage may lead to arbitrary code execution

> Attackers can execute arbitrary code by tricking users into loading malicious checkpoints in the MONAI AI toolkit due to insecure deserialization practices.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-6vm5-6jv9-rjpj, PYSEC-2025-141

## What is CVE-2025-58756?

CVE-2025-58756 is a high-severity unsafe deserialization vulnerability in Project-MONAI MONAI, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MONAI (Medical Open Network for AI) is an AI toolkit for health care imaging. In versions up to and including 1.5.0, in `model_dict = torch.load(full_path, map_location=torch.device(device), weights_only=True)` in monai/bundle/scripts.py , `weights_only=True` is loaded securely. However, insecure loading methods still exist elsewhere in the project, such as when loading checkpoints. This is a common practice when users want to reduce training time and costs by loading pre-trained models downloaded from other platforms. Loading a checkpoint containing malicious content can trigger a deserialization vulnerability, leading to code execution. As of time of publication, no known fixed versions are available.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-58756?

3 open source packages ship an affected version, including monai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `monai` | PyPI | All versions | 1.5.1 |
| `monai` | PyPI | All versions | 1.5.1 |
| `monai` | PyPI | All versions | 1.5.1rc1 |

Products: Monai Medical Open Network for Ai.

## How do I fix CVE-2025-58756?

Upgrade monai to a fixed version for your release line: 1.5.1 or 1.5.1rc1.

## Is CVE-2025-58756 being exploited?

There is no known exploitation of CVE-2025-58756 in the wild and no public exploit code.

## Other vulnerabilities in Project-MONAI MONAI

- [CVE-2025-58755](https://insights.sbomify.com/CVE-2025-58755/): MONAI has path traversal issue that may lead to arbitrary file writes (high 8.8)
- [CVE-2025-58757](https://insights.sbomify.com/CVE-2025-58757/): MONAI's unsafe use of Pickle deserialization may lead to RCE (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58756 and fix it if it is affected.

What it is: CVE-2025-58756 is a high-severity unsafe deserialization vulnerability in Project-MONAI MONAI, published on 8 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58756 in the wild and no public exploit code.

Affected packages and fixed versions:
- monai (PyPI): affected all versions; fixed in 1.5.1
- monai (PyPI): affected all versions; fixed in 1.5.1
- monai (PyPI): affected all versions; fixed in 1.5.1rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58756/ (Markdown: https://insights.sbomify.com/CVE-2025-58756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58756
- OSV: https://osv.dev/vulnerability/CVE-2025-58756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58756/
Summaries are generated and may contain mistakes; the official description above is the record.
