{"answers":{"affected":"4 open source packages ship an affected version, including datahihi1/tiny-env. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58758 in the wild and no public exploit code.","fix":"Upgrade datahihi1/tiny-env to a fixed version for your release line: 1.0.3 or 1.0.11.","what":"CVE-2025-58758 is a medium-severity vulnerability in datahihi1 tiny-env, published on 9 Sep 2025."},"fix_prompt":"Check this codebase for CVE-2025-58758 and fix it if it is affected.\n\nWhat it is: CVE-2025-58758 is a medium-severity vulnerability in datahihi1 tiny-env, published on 9 Sep 2025. \nExploitation: There is no known exploitation of CVE-2025-58758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- datahihi1/tiny-env (Packagist): affected all versions; fixed in 1.0.3\n- datahihi1/tiny-env (Packagist): affected all versions; fixed in 1.0.3\n- datahihi1/tiny-env (Packagist): affected from 1.0.9; fixed in 1.0.11\n- datahihi1/tiny-env (Packagist): affected from 1.0.9; fixed in 1.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58758/ (Markdown: https://insights.sbomify.com/CVE-2025-58758/index.md)","id":"CVE-2025-58758","markdown":"https://insights.sbomify.com/CVE-2025-58758/index.md","name":"CVE-2025-58758","record":{"aliases":["GHSA-3j7m-5g4q-gfpc"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"tinyenv","vendor":"datahihi1"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-703","name":"Improper Check or Handling of Exceptional Conditions"}],"description":"TinyEnv is an environment variable loader for PHP applications. In versions 1.0.1, 1.0.2, 1.0.9, and 1.0.10, TinyEnv did not require the `.env` file to exist when loading environment variables. This could lead to unexpected behavior where the application silently ignores missing configuration, potentially causing insecure defaults or deployment misconfigurations. The issue has been fixed in version 1.0.11. All users should upgrade to 1.0.11 or later. As a workaround, users can manually verify the existence of the `.env` file before initializing TinyEnv.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TinyEnv: Missing .env file not required — may cause unexpected behavior","id":"CVE-2025-58758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"TinyEnv: Inline comments not stripped properly in .env values","id":"CVE-2025-58759"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"datahihi1/tiny-env","purl":null,"source":"GHSA-3j7m-5g4q-gfpc"},{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"datahihi1/tiny-env","purl":"pkg:composer/datahihi1/tiny-env","source":"GHSA-3j7m-5g4q-gfpc"},{"ecosystem":"Packagist","fixed":["1.0.11"],"introduced":["1.0.9"],"last_affected":[],"package":"datahihi1/tiny-env","purl":null,"source":"GHSA-3j7m-5g4q-gfpc"},{"ecosystem":"Packagist","fixed":["1.0.11"],"introduced":["1.0.9"],"last_affected":[],"package":"datahihi1/tiny-env","purl":"pkg:composer/datahihi1/tiny-env","source":"GHSA-3j7m-5g4q-gfpc"}],"prev":{"headline":"MONAI's unsafe use of Pickle deserialization may lead to RCE","id":"CVE-2025-58757"},"products":["tiny-env"],"published":"2025-09-09","related":[{"cvss_score":5.1,"headline":"TinyEnv: Inline comments not stripped properly in .env values","id":"CVE-2025-58759","kev_date_added":null,"published":"2025-09-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["datahihi1"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-58758/"}