{"answers":{"affected":"2 open source packages ship an affected version, including datahihi1/tiny-env. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58759 in the wild and no public exploit code.","fix":"Upgrade datahihi1/tiny-env to 1.0.11 or later.","what":"CVE-2025-58759 is a medium-severity vulnerability in datahihi1 tiny-env, published on 9 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58759 and fix it if it is affected.\n\nWhat it is: CVE-2025-58759 is a medium-severity vulnerability in datahihi1 tiny-env, published on 9 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58759 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- datahihi1/tiny-env (Packagist): affected from 1.0.9; fixed in 1.0.11\n- datahihi1/tiny-env (Packagist): affected from 1.0.9; fixed in 1.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58759/ (Markdown: https://insights.sbomify.com/CVE-2025-58759/index.md)","id":"CVE-2025-58759","markdown":"https://insights.sbomify.com/CVE-2025-58759/index.md","name":"CVE-2025-58759","record":{"aliases":["GHSA-72cm-7236-h43r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP environment loader","requires_auth":"none","summary":"Improper stripping of inline comments in .env files can cause misconfigurations, potentially leading to authentication failures or insecure defaults in PHP applications.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tinyenv","vendor":"datahihi1"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"TinyEnv is an environment variable loader for PHP applications. In versions 1.0.9 and 1.0.10, TinyEnv did not properly strip inline comments inside .env values. This could lead to unexpected behavior or misconfiguration, where variables contain unintended characters (including # or comment text). Applications depending on strict environment values may expose logic errors, insecure defaults, or failed authentication. The issue is fixed in v1.0.11. Users should upgrade to the latest patched version. As a temporary workaround, avoid using inline comments in .env files, or sanitize loaded values manually.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TinyEnv: Inline comments not stripped properly in .env values","id":"CVE-2025-58759","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"misconfiguration","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Tautulli vulnerable to Unauthenticated Path Traversal in `/image` endpoint","id":"CVE-2025-58760"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.11"],"introduced":["1.0.9"],"last_affected":[],"package":"datahihi1/tiny-env","purl":null,"source":"GHSA-72cm-7236-h43r"},{"ecosystem":"Packagist","fixed":["1.0.11"],"introduced":["1.0.9"],"last_affected":[],"package":"datahihi1/tiny-env","purl":"pkg:composer/datahihi1/tiny-env","source":"GHSA-72cm-7236-h43r"}],"prev":{"headline":"TinyEnv: Missing .env file not required — may cause unexpected behavior","id":"CVE-2025-58758"},"products":["tiny-env"],"published":"2025-09-09","related":[{"cvss_score":5.1,"headline":"TinyEnv: Missing .env file not required — may cause unexpected behavior","id":"CVE-2025-58758","kev_date_added":null,"published":"2025-09-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["datahihi1"]},"summary":"Improper stripping of inline comments in .env files can cause misconfigurations, potentially leading to authentication failures or insecure defaults in PHP applications.","url":"https://insights.sbomify.com/CVE-2025-58759/"}