# CVE-2025-58762: Tautulli vulnerable to Authenticated Remote Code Execution via write primitive and `Script` notification agent

> Administrative attackers can exploit path traversal in image proxy to write scripts, achieving remote code execution via notification agents.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** GHSA-pxhr-29gv-4j8v

## What is CVE-2025-58762?

CVE-2025-58762 is a critical path traversal vulnerability in Tautulli, published on 9 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Tautulli is a Python based monitoring and tracking tool for Plex Media Server. In Tautulli v2.15.3 and earlier, an attacker with administrative access can use the `pms_image_proxy` endpoint to write arbitrary python scripts into the application filesystem. This leads to remote code execution when combined with the `Script` notification agent. If an attacker with administrative access changes the URL of the PMS to a server they control, they can then abuse the `pms_image_proxy` to obtain a file write into the application filesystem. This can be done by making a `pms_image_proxy` request with a URL in the `img` parameter and the desired file name in the `img_format` parameter. Tautulli then uses a hash of the desired metadata together with the `img_format` in order to construct a file path. Since the attacker controls `img_format` which occupies the end of the file path, and `img_format` is not sanitised, the attacker can then use path traversal characters to specify filename of their choosing. If the specified file does not exist, Tautaulli will then attempt to fetch the image from the configured PMS. Since the attacker controls the PMS, they can return arbitrary content in response to this request, which will then be written into the specified file. An attacker can write an arbitrary python script into a location on the application file system. The attacker can then make use of the built-in `Script` notification agent to run the local script, obtaining remote code execution on the application server. Users should upgrade to version 2.16.0 to receive a patch.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-58762?

It affects 1 product.


Products: Tautulli Tautulli.

## How do I fix CVE-2025-58762?

No fix has been published for CVE-2025-58762 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58762 being exploited?

There is no known exploitation of CVE-2025-58762 in the wild and no public exploit code.

## Other vulnerabilities in Tautulli

- [CVE-2026-31831](https://insights.sbomify.com/CVE-2026-31831/): Tautulli: Unauthenticated Path Traversal in `/newsletter/image/images` endpoint (high 8.7)
- [CVE-2025-58760](https://insights.sbomify.com/CVE-2025-58760/): Tautulli vulnerable to Unauthenticated Path Traversal in `/image` endpoint (high 8.6)
- [CVE-2025-58761](https://insights.sbomify.com/CVE-2025-58761/): Tautulli vulnerable to Unauthenticated Path Traversal in `real_pms_image_proxy` (high 8.6)
- [CVE-2025-58763](https://insights.sbomify.com/CVE-2025-58763/): Tautulli vulnerable to Authenticated Remote Code Execution via Command Injection (high 8.1)
- [CVE-2026-28505](https://insights.sbomify.com/CVE-2026-28505/): Tautulli: RCE via eval() sandbox bypass using lambda nested scope to escape co_names whitelist check (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58762 and fix it if it is affected.

What it is: CVE-2025-58762 is a critical path traversal vulnerability in Tautulli, published on 9 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58762 in the wild and no public exploit code.

Affected product: Tautulli. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58762/ (Markdown: https://insights.sbomify.com/CVE-2025-58762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58762
- OSV: https://osv.dev/vulnerability/CVE-2025-58762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58762/
Summaries are generated and may contain mistakes; the official description above is the record.
