# CVE-2025-58764: Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution

> Attackers can bypass user approval prompts to execute arbitrary commands by injecting untrusted content into the context window.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2025
- **Updated:** 11 Sep 2025
- **Also known as:** GHSA-qxfv-fcpc-w36x

## What is CVE-2025-58764?

CVE-2025-58764 is a high-severity command injection vulnerability in anthropics claude-code, published on 10 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-58764?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 1.0.105 |
| `@anthropic-ai/claude-code` | npm | All versions | 1.0.105 |

Products: Anthropic Claude Code.

## How do I fix CVE-2025-58764?

Upgrade @anthropic-ai/claude-code to 1.0.105 or later.

## Is CVE-2025-58764 being exploited?

There is no known exploitation of CVE-2025-58764 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)
- [CVE-2025-54795](https://insights.sbomify.com/CVE-2025-54795/): Claude Code echo command allowed bypass of user approval prompt for command execution (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58764 and fix it if it is affected.

What it is: CVE-2025-58764 is a high-severity command injection vulnerability in anthropics claude-code, published on 10 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58764 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.105
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.105

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58764/ (Markdown: https://insights.sbomify.com/CVE-2025-58764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58764
- OSV: https://osv.dev/vulnerability/CVE-2025-58764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58764/
Summaries are generated and may contain mistakes; the official description above is the record.
