CVE-2025-58769 auth0-PHP: Improper File Type Handling in Bulk User Import
Attackers can exploit improper file path validation in the Bulk User Import endpoint to access arbitrary files or URLs via the Auth0-PHP SDK.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58769?
CVE-2025-58769 is a low-severity path traversal vulnerability in laravel-auth0, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
Which versions are affected by CVE-2025-58769?
2 open source packages ship an affected version, including auth0/auth0-php.
| Package | Affected | Fixed in |
|---|---|---|
auth0/auth0-php Packagist | From 3.3.0 | 8.17.0 |
auth0/auth0-php Packagist | From 3.3.0 | 8.17.0 |
How do I fix CVE-2025-58769?
Upgrade auth0/auth0-php to 8.17.0 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-58769 being exploited?
There is no known exploitation of CVE-2025-58769 in the wild and no public exploit code.
Sources
Also known as GHSA-9mh6-g99m-ppcw.