{"answers":{"affected":"2 open source packages ship an affected version, including auth0/auth0-php.","exploited":"There is no known exploitation of CVE-2025-58769 in the wild and no public exploit code.","fix":"Upgrade auth0/auth0-php to 8.17.0 or later.","what":"CVE-2025-58769 is a low-severity path traversal vulnerability in laravel-auth0, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58769 and fix it if it is affected.\n\nWhat it is: CVE-2025-58769 is a low-severity path traversal vulnerability in laravel-auth0, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58769 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/auth0-php (Packagist): affected from 3.3.0; fixed in 8.17.0\n- auth0/auth0-php (Packagist): affected from 3.3.0; fixed in 8.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58769/ (Markdown: https://insights.sbomify.com/CVE-2025-58769/index.md)","id":"CVE-2025-58769","markdown":"https://insights.sbomify.com/CVE-2025-58769/index.md","name":"CVE-2025-58769","record":{"aliases":["GHSA-9mh6-g99m-ppcw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Auth0 SDK","requires_auth":"high_privilege","summary":"Attackers can exploit improper file path validation in the Bulk User Import endpoint to access arbitrary files or URLs via the Auth0-PHP SDK.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"auth0-PHP: Improper File Type Handling in Bulk User Import","id":"CVE-2025-58769","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":6,"next":{"headline":"TCG2 TPM RT Not Locked Issue","id":"CVE-2025-58770"},"packages":[{"ecosystem":"Packagist","fixed":["8.17.0"],"introduced":["3.3.0"],"last_affected":[],"package":"auth0/auth0-php","purl":null,"source":"GHSA-9mh6-g99m-ppcw"},{"ecosystem":"Packagist","fixed":["8.17.0"],"introduced":["3.3.0"],"last_affected":[],"package":"auth0/auth0-php","purl":"pkg:composer/auth0/auth0-php","source":"GHSA-9mh6-g99m-ppcw"}],"prev":{"headline":"DeepChat's Mermaid rendering has XSS leading to RCE","id":"CVE-2025-58768"},"products":["laravel-auth0"],"published":"2025-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-01","vendors":["auth0"]},"summary":"Attackers can exploit improper file path validation in the Bulk User Import endpoint to access arbitrary files or URLs via the Auth0-PHP SDK.","url":"https://insights.sbomify.com/CVE-2025-58769/"}