# CVE-2025-58769: auth0-PHP: Improper File Type Handling in Bulk User Import

> Attackers can exploit improper file path validation in the Bulk User Import endpoint to access arbitrary files or URLs via the Auth0-PHP SDK.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 1 Oct 2025
- **Also known as:** GHSA-9mh6-g99m-ppcw

## What is CVE-2025-58769?

CVE-2025-58769 is a low-severity path traversal vulnerability in laravel-auth0, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-58769?

2 open source packages ship an affected version, including auth0/auth0-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/auth0-php` | Packagist | From 3.3.0 | 8.17.0 |
| `auth0/auth0-php` | Packagist | From 3.3.0 | 8.17.0 |

## How do I fix CVE-2025-58769?

Upgrade auth0/auth0-php to 8.17.0 or later.

## Is CVE-2025-58769 being exploited?

There is no known exploitation of CVE-2025-58769 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58769 and fix it if it is affected.

What it is: CVE-2025-58769 is a low-severity path traversal vulnerability in laravel-auth0, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58769 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/auth0-php (Packagist): affected from 3.3.0; fixed in 8.17.0
- auth0/auth0-php (Packagist): affected from 3.3.0; fixed in 8.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58769/ (Markdown: https://insights.sbomify.com/CVE-2025-58769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58769
- OSV: https://osv.dev/vulnerability/CVE-2025-58769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58769/
Summaries are generated and may contain mistakes; the official description above is the record.
