{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.jackrabbit:jackrabbit-core and org.apache.jackrabbit:jackrabbit-jcr-commons. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58782 in the wild and no public exploit code.","fix":"Upgrade org.apache.jackrabbit:jackrabbit-core to 2.22.2 or later.","what":"CVE-2025-58782 is a medium-severity unsafe deserialization vulnerability in Apache Jackrabbit Core, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58782 and fix it if it is affected.\n\nWhat it is: CVE-2025-58782 is a medium-severity unsafe deserialization vulnerability in Apache Jackrabbit Core, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58782 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.jackrabbit:jackrabbit-core (Maven): affected from 1.0.0; fixed in 2.22.2\n- org.apache.jackrabbit:jackrabbit-core (Maven): affected from 1.0.0; fixed in 2.22.2\n- org.apache.jackrabbit:jackrabbit-jcr-commons (Maven): affected from 1.0.0; fixed in 2.22.2\n- org.apache.jackrabbit:jackrabbit-jcr-commons (Maven): affected from 1.0.0; fixed in 2.22.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58782/ (Markdown: https://insights.sbomify.com/CVE-2025-58782/index.md)","id":"CVE-2025-58782","markdown":"https://insights.sbomify.com/CVE-2025-58782/index.md","name":"CVE-2025-58782","record":{"aliases":["DEBIAN-CVE-2025-58782","GHSA-cxvc-g8f2-4gmm","UBUNTU-CVE-2025-58782"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java content repository library","requires_auth":"none","summary":"Attackers can achieve arbitrary code execution via JNDI injection if JCR lookup from untrusted users is enabled, requiring an upgrade to disable this feature by default.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"jackrabbit","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons.\n\nThis issue affects Apache Jackrabbit Core: from 1.0.0 through 2.22.1; Apache Jackrabbit JCR Commons: from 1.0.0 through 2.22.1.\n\nDeployments that accept JNDI URIs for JCR lookup from untrusted users allows them to inject malicious JNDI references, potentially leading to arbitrary code execution through deserialization of untrusted data.\nUsers are recommended to upgrade to version 2.22.2. JCR lookup through JNDI has been disabled by default in 2.22.2. Users of this feature need to enable it explicitly and are adviced to review their use of JNDI URI for JCR lookup.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory","id":"CVE-2025-58782","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"WordPress Gutentor plugin \u003c= 3.5.5 - Broken Access Control vulnerability","id":"CVE-2025-58783"},"packages":[{"ecosystem":"Maven","fixed":["2.22.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit-core","purl":null,"source":"GHSA-cxvc-g8f2-4gmm"},{"ecosystem":"Maven","fixed":["2.22.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit-core","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-core","source":"GHSA-cxvc-g8f2-4gmm"},{"ecosystem":"Maven","fixed":["2.22.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit-jcr-commons","purl":null,"source":"GHSA-cxvc-g8f2-4gmm"},{"ecosystem":"Maven","fixed":["2.22.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit-jcr-commons","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit-jcr-commons","source":"GHSA-cxvc-g8f2-4gmm"}],"prev":{"headline":"Weak cryptography in WTW-EAGLE App for Android","id":"CVE-2025-58781"},"products":["Apache Jackrabbit Core","Apache Jackrabbit JCR Commons"],"published":"2025-09-08","related":[{"cvss_score":9.8,"headline":"Apache Jackrabbit RMI access can lead to RCE","id":"CVE-2023-37895","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":9.3,"headline":"Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens","id":"CVE-2026-92414","kev_date_added":null,"published":"2026-10-07"},{"cvss_score":8.8,"headline":"Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons","id":"CVE-2025-53689","kev_date_added":null,"published":"2025-07-14"},{"cvss_score":8.8,"headline":"Apache Jackrabbit Authentication Hijacking Vulnerability","id":"CVE-2016-6801","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":6.9,"headline":"Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies","id":"CVE-2026-92415","kev_date_added":null,"published":"2026-10-07"},{"cvss_score":6.4,"headline":"Improper Input Validation in Apache Jackrabbit","id":"CVE-2015-1833","kev_date_added":null,"published":"2015-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can achieve arbitrary code execution via JNDI injection if JCR lookup from untrusted users is enabled, requiring an upgrade to disable this feature by default.","url":"https://insights.sbomify.com/CVE-2025-58782/"}