CVE-2025-5889 juliangruber brace-expansion index.js expand redos
Remote attackers can cause denial of service via inefficient regular expression complexity in the brace-expansion library, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-5889?
CVE-2025-5889 is a low-severity denial of service vulnerability in juliangruber brace-expansion, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2025-5889?
8 open source packages ship an affected version, including brace-expansion.
| Package | Affected | Fixed in |
|---|---|---|
brace-expansion npm | From 1.0.0 | 1.1.12 |
brace-expansion npm | From 1.0.0 | 1.1.12 |
brace-expansion npm | From 2.0.0 | 2.0.2 |
brace-expansion npm | From 2.0.0 | 2.0.2 |
brace-expansion npm | From 3.0.0 | 3.0.1 |
brace-expansion npm | From 3.0.0 | 3.0.1 |
2 more packages
brace-expansion npm | From 4.0.0 | 4.0.1 |
brace-expansion npm | From 4.0.0 | 4.0.1 |
Linux distribution packages (10)
python-bqplot openSUSE:Tumbleweed | All versions | 0.12.45-10.1 |
python-furo openSUSE:Tumbleweed | All versions | 2024.8.6-3.1 |
python-ipympl openSUSE:Tumbleweed | All versions | 0.9.4-15.1 |
python-jupyter-ydoc openSUSE:Tumbleweed | All versions | 3.1.0-1.1 |
python-jupyterlab-templates openSUSE:Tumbleweed | All versions | 0.5.2-2.1 |
python-nbclassic openSUSE:Tumbleweed | All versions | 1.3.1-1.1 |
python-nbdime openSUSE:Tumbleweed | All versions | 4.0.2-20.1 |
python-panel openSUSE:Tumbleweed | All versions | 1.7.1-1.1 |
python-plotly openSUSE:Tumbleweed | All versions | 6.1.2-1.1 |
python-pydata-sphinx-theme openSUSE:Tumbleweed | All versions | 0.16.1-1.1 |
How do I fix CVE-2025-5889?
Upgrade brace-expansion to a fixed version for your release line: 1.1.12, 2.0.2, 3.0.1 or 4.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-5889 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5889 exists.
Sources
Also known as AZL-63689, AZL-63692, AZL-63704, AZL-63707, AZL-63881, CLEANSTART-2026-IZ17087 and 35 more.