{"answers":{"affected":"2 open source packages ship an affected version, including pm2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5891 exists.","fix":"Upgrade pm2 to 7.0.0 or later.","what":"CVE-2025-5891 is a medium-severity denial of service vulnerability in Unitech pm2, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5891 and fix it if it is affected.\n\nWhat it is: CVE-2025-5891 is a medium-severity denial of service vulnerability in Unitech pm2, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5891 exists.\n\nAffected packages and fixed versions:\n- pm2 (npm): affected all versions; fixed in 7.0.0\n- pm2 (npm): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5891/ (Markdown: https://insights.sbomify.com/CVE-2025-5891/index.md)","id":"CVE-2025-5891","markdown":"https://insights.sbomify.com/CVE-2025-5891/index.md","name":"CVE-2025-5891","record":{"aliases":["GHSA-x5gf-qvw8-r2rm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js process manager","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in Unitech pm2 via inefficient regular expressions in the configuration module.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pm2","vendor":"keymetric"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Unitech pm2 Config.js redos","id":"CVE-2025-5891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"RocketChat parseMessage.js parseMessage redos","id":"CVE-2025-5892"},"packages":[{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"pm2","purl":null,"source":"GHSA-x5gf-qvw8-r2rm"},{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"pm2","purl":"pkg:npm/pm2","source":"GHSA-x5gf-qvw8-r2rm"}],"prev":{"headline":"actions toolkit glob internal-pattern.ts globEscape redos","id":"CVE-2025-5890"},"products":["pm2"],"published":"2025-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-09","vendors":["Unitech"]},"summary":"Remote attackers can cause denial of service in Unitech pm2 via inefficient regular expressions in the configuration module.","url":"https://insights.sbomify.com/CVE-2025-5891/"}