# CVE-2025-5891: Unitech pm2 Config.js redos

> Remote attackers can cause denial of service in Unitech pm2 via inefficient regular expressions in the configuration module.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-x5gf-qvw8-r2rm

## What is CVE-2025-5891?

CVE-2025-5891 is a medium-severity denial of service vulnerability in Unitech pm2, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-5891?

2 open source packages ship an affected version, including pm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pm2` | npm | All versions | 7.0.0 |
| `pm2` | npm | All versions | 7.0.0 |

Products: Keymetric Pm2.

## How do I fix CVE-2025-5891?

Upgrade pm2 to 7.0.0 or later.

## Is CVE-2025-5891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5891 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5891 and fix it if it is affected.

What it is: CVE-2025-5891 is a medium-severity denial of service vulnerability in Unitech pm2, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5891 exists.

Affected packages and fixed versions:
- pm2 (npm): affected all versions; fixed in 7.0.0
- pm2 (npm): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5891/ (Markdown: https://insights.sbomify.com/CVE-2025-5891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5891
- OSV: https://osv.dev/vulnerability/CVE-2025-5891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5891/
Summaries are generated and may contain mistakes; the official description above is the record.
