# CVE-2025-59035: Indico vulnerable to Cross-Site Scripting via LaTeX math code

> Attackers can inject malicious scripts via LaTeX math in event descriptions, potentially compromising user sessions and data.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Sep 2025
- **Updated:** 11 Sep 2025
- **Also known as:** GHSA-7cf7-9wrr-vrf4, PYSEC-2026-1461

## What is CVE-2025-59035?

CVE-2025-59035 is a medium-severity cross-site scripting vulnerability in indico, published on 10 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, there is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59035?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.8 |
| `indico` | PyPI | All versions | 3.3.8 |
| `indico` | PyPI | All versions | 3.3.8 |

Products: Cern Indico.

## How do I fix CVE-2025-59035?

Upgrade indico to 3.3.8 or later.

## Is CVE-2025-59035 being exploited?

There is no known exploitation of CVE-2025-59035 in the wild and no public exploit code.

## Other vulnerabilities in indico

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59035 and fix it if it is affected.

What it is: CVE-2025-59035 is a medium-severity cross-site scripting vulnerability in indico, published on 10 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59035 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.8
- indico (PyPI): affected all versions; fixed in 3.3.8
- indico (PyPI): affected all versions; fixed in 3.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59035/ (Markdown: https://insights.sbomify.com/CVE-2025-59035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59035
- OSV: https://osv.dev/vulnerability/CVE-2025-59035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59035/
Summaries are generated and may contain mistakes; the official description above is the record.
