{"answers":{"affected":"5 open source packages ship an affected version, including infrahub-server.","exploited":"There is no known exploitation of CVE-2025-59036 in the wild and no public exploit code.","fix":"Upgrade infrahub-server to a fixed version for your release line: 1.3.9 or 1.4.5.","what":"CVE-2025-59036 is a medium-severity authentication bypass vulnerability in opsmill infrahub, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59036 and fix it if it is affected.\n\nWhat it is: CVE-2025-59036 is a medium-severity authentication bypass vulnerability in opsmill infrahub, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59036 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- infrahub-server (PyPI): affected all versions; fixed in 1.3.9, 1.4.5\n- infrahub-server (PyPI): affected all versions; fixed in 1.3.9\n- infrahub-server (PyPI): affected all versions; fixed in 1.3.9\n- infrahub-server (PyPI): affected from 1.4.0; fixed in 1.4.5\n- infrahub-server (PyPI): affected from 1.4.0; fixed in 1.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59036/ (Markdown: https://insights.sbomify.com/CVE-2025-59036/index.md)","id":"CVE-2025-59036","markdown":"https://insights.sbomify.com/CVE-2025-59036/index.md","name":"CVE-2025-59036","record":{"aliases":["GHSA-v2p7-4pv4-3wwh","PYSEC-2026-1463"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Infrahub data hub","requires_auth":"low_privilege","summary":"Attackers can authenticate using deleted or expired API tokens, bypassing intended access controls in Infrahub.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-298","name":"Improper Validation of Certificate Expiration"}],"description":"Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Infrahub allows authentication with deleted and expired API tokens","id":"CVE-2025-59036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":5,"n_references":1,"next":{"headline":"DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware","id":"CVE-2025-59037"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.9","1.4.5"],"introduced":["0","1.4.0"],"last_affected":[],"package":"infrahub-server","purl":"pkg:pypi/infrahub-server","source":"PYSEC-2026-1463"},{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0"],"last_affected":[],"package":"infrahub-server","purl":null,"source":"GHSA-v2p7-4pv4-3wwh"},{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0"],"last_affected":[],"package":"infrahub-server","purl":"pkg:pypi/infrahub-server","source":"GHSA-v2p7-4pv4-3wwh"},{"ecosystem":"PyPI","fixed":["1.4.5"],"introduced":["1.4.0"],"last_affected":[],"package":"infrahub-server","purl":null,"source":"GHSA-v2p7-4pv4-3wwh"},{"ecosystem":"PyPI","fixed":["1.4.5"],"introduced":["1.4.0"],"last_affected":[],"package":"infrahub-server","purl":"pkg:pypi/infrahub-server","source":"GHSA-v2p7-4pv4-3wwh"}],"prev":{"headline":"Indico vulnerable to Cross-Site Scripting via LaTeX math code","id":"CVE-2025-59035"},"products":["infrahub"],"published":"2025-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["opsmill"]},"summary":"Attackers can authenticate using deleted or expired API tokens, bypassing intended access controls in Infrahub.","url":"https://insights.sbomify.com/CVE-2025-59036/"}