# CVE-2025-59036: Infrahub allows authentication with deleted and expired API tokens

> Attackers can authenticate using deleted or expired API tokens, bypassing intended access controls in Infrahub.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** GHSA-v2p7-4pv4-3wwh, PYSEC-2026-1463

## What is CVE-2025-59036?

CVE-2025-59036 is a medium-severity authentication bypass vulnerability in opsmill infrahub, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.

Weakness: CWE-298 (Improper Validation of Certificate Expiration)

## Which versions are affected by CVE-2025-59036?

5 open source packages ship an affected version, including infrahub-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `infrahub-server` | PyPI | All versions | 1.3.9, 1.4.5 |
| `infrahub-server` | PyPI | All versions | 1.3.9 |
| `infrahub-server` | PyPI | All versions | 1.3.9 |
| `infrahub-server` | PyPI | From 1.4.0 | 1.4.5 |
| `infrahub-server` | PyPI | From 1.4.0 | 1.4.5 |

## How do I fix CVE-2025-59036?

Upgrade infrahub-server to a fixed version for your release line: 1.3.9 or 1.4.5.

## Is CVE-2025-59036 being exploited?

There is no known exploitation of CVE-2025-59036 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59036 and fix it if it is affected.

What it is: CVE-2025-59036 is a medium-severity authentication bypass vulnerability in opsmill infrahub, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59036 in the wild and no public exploit code.

Affected packages and fixed versions:
- infrahub-server (PyPI): affected all versions; fixed in 1.3.9, 1.4.5
- infrahub-server (PyPI): affected all versions; fixed in 1.3.9
- infrahub-server (PyPI): affected all versions; fixed in 1.3.9
- infrahub-server (PyPI): affected from 1.4.0; fixed in 1.4.5
- infrahub-server (PyPI): affected from 1.4.0; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59036/ (Markdown: https://insights.sbomify.com/CVE-2025-59036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59036
- OSV: https://osv.dev/vulnerability/CVE-2025-59036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59036/
Summaries are generated and may contain mistakes; the official description above is the record.
