CVE-2025-59037 DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
Attackers injected malware into DuckDB Node.js packages to interfere with cryptocurrency transactions, requiring users to upgrade or downgrade to safe versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-59037?
CVE-2025-59037 is a high-severity vulnerability in duckdb-node, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.
Weakness: CWE-506
Which versions are affected by CVE-2025-59037?
8 open source packages ship an affected version, including @duckdb/duckdb-wasm, @duckdb/node-api and @duckdb/node-bindings.
| Package | Affected | Fixed in |
|---|---|---|
@duckdb/duckdb-wasm npm | From 1.29.2 | 1.30.0 |
@duckdb/duckdb-wasm npm | From 1.29.2 | 1.30.0 |
@duckdb/node-api npm | From 1.3.3 | 1.3.4-alpha.27 |
@duckdb/node-api npm | From 1.3.3 | 1.3.4-alpha.27 |
@duckdb/node-bindings npm | From 1.3.3 | 1.3.4-alpha.27 |
@duckdb/node-bindings npm | From 1.3.3 | 1.3.4-alpha.27 |
2 more packages
duckdb npm | From 1.3.3 | 1.3.4 |
duckdb npm | From 1.3.3 | 1.3.4 |
How do I fix CVE-2025-59037?
Upgrade @duckdb/duckdb-wasm to 1.30.0 or later.
Is CVE-2025-59037 being exploited?
There is no known exploitation of CVE-2025-59037 in the wild and no public exploit code.
Sources
Also known as GHSA-w62p-hx95-gf2c.