{"answers":{"affected":"8 open source packages ship an affected version, including @duckdb/duckdb-wasm, @duckdb/node-api and @duckdb/node-bindings.","exploited":"There is no known exploitation of CVE-2025-59037 in the wild and no public exploit code.","fix":"Upgrade @duckdb/duckdb-wasm to 1.30.0 or later.","what":"CVE-2025-59037 is a high-severity vulnerability in duckdb-node, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59037 and fix it if it is affected.\n\nWhat it is: CVE-2025-59037 is a high-severity vulnerability in duckdb-node, published on 9 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59037 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @duckdb/duckdb-wasm (npm): affected from 1.29.2; fixed in 1.30.0\n- @duckdb/duckdb-wasm (npm): affected from 1.29.2; fixed in 1.30.0\n- @duckdb/node-api (npm): affected from 1.3.3; fixed in 1.3.4-alpha.27\n- @duckdb/node-api (npm): affected from 1.3.3; fixed in 1.3.4-alpha.27\n- @duckdb/node-bindings (npm): affected from 1.3.3; fixed in 1.3.4-alpha.27\n- @duckdb/node-bindings (npm): affected from 1.3.3; fixed in 1.3.4-alpha.27\n- duckdb (npm): affected from 1.3.3; fixed in 1.3.4\n- duckdb (npm): affected from 1.3.3; fixed in 1.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59037/ (Markdown: https://insights.sbomify.com/CVE-2025-59037/index.md)","id":"CVE-2025-59037","markdown":"https://insights.sbomify.com/CVE-2025-59037/index.md","name":"CVE-2025-59037","record":{"aliases":["GHSA-w62p-hx95-gf2c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"DuckDB Node.js library","requires_auth":"none","summary":"Attackers injected malware into DuckDB Node.js packages to interfere with cryptocurrency transactions, requiring users to upgrade or downgrade to safe versions.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-506","name":"Embedded Malicious Code"}],"description":"DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/node-api@1.3.3`, `@duckdb/node-bindings@1.3.3`, `duckdb@1.3.3`, and `@duckdb/duckdb-wasm@1.29.2` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware","id":"CVE-2025-59037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2025"},"n_packages":8,"n_references":3,"next":{"headline":"Prebid.js NPM package briefly compromised","id":"CVE-2025-59038"},"packages":[{"ecosystem":"npm","fixed":["1.30.0"],"introduced":["1.29.2"],"last_affected":[],"package":"@duckdb/duckdb-wasm","purl":null,"source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.30.0"],"introduced":["1.29.2"],"last_affected":[],"package":"@duckdb/duckdb-wasm","purl":"pkg:npm/%40duckdb/duckdb-wasm","source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4-alpha.27"],"introduced":["1.3.3"],"last_affected":[],"package":"@duckdb/node-api","purl":null,"source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4-alpha.27"],"introduced":["1.3.3"],"last_affected":[],"package":"@duckdb/node-api","purl":"pkg:npm/%40duckdb/node-api","source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4-alpha.27"],"introduced":["1.3.3"],"last_affected":[],"package":"@duckdb/node-bindings","purl":null,"source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4-alpha.27"],"introduced":["1.3.3"],"last_affected":[],"package":"@duckdb/node-bindings","purl":"pkg:npm/%40duckdb/node-bindings","source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["1.3.3"],"last_affected":[],"package":"duckdb","purl":null,"source":"GHSA-w62p-hx95-gf2c"},{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["1.3.3"],"last_affected":[],"package":"duckdb","purl":"pkg:npm/duckdb","source":"GHSA-w62p-hx95-gf2c"}],"prev":{"headline":"Infrahub allows authentication with deleted and expired API tokens","id":"CVE-2025-59036"},"products":["duckdb-node"],"published":"2025-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["duckdb"]},"summary":"Attackers injected malware into DuckDB Node.js packages to interfere with cryptocurrency transactions, requiring users to upgrade or downgrade to safe versions.","url":"https://insights.sbomify.com/CVE-2025-59037/"}